How to Upgrade AutoIndex to PHP 7

I posted back in September 2017 that I am a fan of the AutoIndex 2.2.4 PHP script. See my post “Bootsrap 3 Responsive Template for AutoIndex PHP Script“.

Many ISPs and web designers are moving to PHP  7.x, the current version of PHP.  Unfortunately this causes AutoIndex 2.2.4 to stop working. It will throw an error referring to a magic_quotes function call on line 122 of the index.php file:

Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime()

The magic_quotes function was taken out of PHP 7.x. But have no fear, it turns out that the solution is not too difficult.   Continue reading “How to Upgrade AutoIndex to PHP 7”